查看: 10463|回复: 1

[验证开发] 第六节:易语言开发实例【登录初始化】

[复制链接]
发表于 2018-12-27 14:14:49 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区

您需要 登录 才可以下载或查看,没有账号?立即注册

x
安装支持库:彗星HTTP支持库1.6版本(内附实例及安装方法)
彗星HTTP操作支持库.jpg
彗星HTTP支持库1.6版本.zip (981.41 KB, 下载次数: 2167)
第一步:新建自定义数据类

.版本 2

.数据类型 新秀用户信息, 公开
    .成员 uid, 文本型, , , 用户uid
    .成员 name, 文本型, , , 用户名
    .成员 groupid, 文本型, , , 会员组id
    .成员 adminid, 文本型, , , 管理组id
    .成员 token, 文本型, , , token令牌
    .成员 sgin, 文本型, , , 卡号
    .成员 datetime, 文本型, , , 计时用户到期时间
    .成员 grouptime, 文本型, , , 用户组到期时间

.数据类型 新秀网络验证设置, 公开
    .成员 域名, 文本型, , , 网站域名带http://
    .成员 key, 文本型, , , 传输密钥
    .成员 adminkey, 文本型, , , 管理密钥
.版本 2

.数据类型 新秀用户信息, 公开
    .成员 uid, 文本型, , , 用户uid
    .成员 name, 文本型, , , 用户名
    .成员 groupid, 文本型, , , 会员组id
    .成员 adminid, 文本型, , , 管理组id
    .成员 token, 文本型, , , token令牌
    .成员 sgin, 文本型, , , 卡号
    .成员 datetime, 文本型, , , 计时用户到期时间
    .成员 grouptime, 文本型, , , 用户组到期时间

.数据类型 新秀网络验证设置, 公开
    .成员 域名, 文本型, , , 网站域名带http://
    .成员 key, 文本型, , , 传输密钥
    .成员 adminkey, 文本型, , , 管理密钥


第二步:新建自定义数据类型

.版本 2
.支持库 CometHttp

.全局变量 用户, 新秀用户信息
.全局变量 设置, 新秀网络验证设置
.全局变量 类_json, 彗星JSON
.全局变量 返回数据, 文本型
.全局变量 API接口拼接, 文本型
.版本 2
.支持库 CometHttp

.全局变量 用户, 新秀用户信息
.全局变量 设置, 新秀网络验证设置
.全局变量 类_json, 彗星JSON
.全局变量 返回数据, 文本型
.全局变量 API接口拼接, 文本型

第三步:写登录接口代码

登录界面.jpg
.版本 2
.支持库 CometHttp

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

加载网站设置 ()

.子程序 _按钮_登陆_被单击
.局部变量 json, 彗星JSON

API接口拼接 = 设置.域名 + “login&key=” + 设置.key + “&action=login_user&username=” + 用户名_输入框.内容 + “&password=” + 密码_输入框.内容
返回数据 = 彗星HTTP读文本 (API接口拼接, , , , , , , , )
类_json.解析 (返回数据, 真)  ' 解析json格式数据
.如果 (类_json.取文本属性 (“code”) = “200”)  ' 判断是否成功:200成功,400是失败
    json = 类_json.查询 (“data”)  ' 查询成功返回数据数组
    用户.uid = json.取文本属性 (“uid”)  ' 赋值全局变量用户类值
    用户.name = json.取文本属性 (“username”)  ' 赋值全局变量用户类值
    用户.groupid = json.取文本属性 (“groupid”)  ' 赋值全局变量用户类值
    用户.adminid = json.取文本属性 (“adminid”)  ' 赋值全局变量用户类值
    用户.token = json.取文本属性 (“token”)  ' 赋值全局变量用户类值
    用户.sgin = json.取文本属性 (“sgin”)  ' 赋值全局变量用户类值
    用户.datetime = json.取文本属性 (“dateline”)  ' 赋值全局变量用户类值
    载入 (用户信息, , 真)
.否则
    信息框 (类_json.取文本属性 (“result”), 48, “错误提示码:”, )
.如果结束


.子程序 加载网站设置

设置.域名 = “http://demo.xinxiuvip.com/plugin.php?id=xinxiu_network:”  ' 设置网站域名头
设置.key = “123456”  ' 设置传输密钥
设置.adminkey = “8888888”  ' 设置管理密钥
.版本 2
.支持库 CometHttp

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

加载网站设置 ()

.子程序 _按钮_登陆_被单击
.局部变量 json, 彗星JSON

API接口拼接 = 设置.域名 + “login&key=” + 设置.key + “&action=login_user&username=” + 用户名_输入框.内容 + “&password=” + 密码_输入框.内容
返回数据 = 彗星HTTP读文本 (API接口拼接, , , , , , , , )
类_json.解析 (返回数据, 真)  ' 解析json格式数据
.如果 (类_json.取文本属性 (“code”) = “200”)  ' 判断是否成功:200成功,400是失败
    json = 类_json.查询 (“data”)  ' 查询成功返回数据数组
    用户.uid = json.取文本属性 (“uid”)  ' 赋值全局变量用户类值
    用户.name = json.取文本属性 (“username”)  ' 赋值全局变量用户类值
    用户.groupid = json.取文本属性 (“groupid”)  ' 赋值全局变量用户类值
    用户.adminid = json.取文本属性 (“adminid”)  ' 赋值全局变量用户类值
    用户.token = json.取文本属性 (“token”)  ' 赋值全局变量用户类值
    用户.sgin = json.取文本属性 (“sgin”)  ' 赋值全局变量用户类值
    用户.datetime = json.取文本属性 (“dateline”)  ' 赋值全局变量用户类值
    载入 (用户信息, , 真)
.否则
    信息框 (类_json.取文本属性 (“result”), 48, “错误提示码:”, )
.如果结束


.子程序 加载网站设置

设置.域名 = “http://demo.xinxiuvip.com/plugin.php?id=xinxiu_network:”  ' 设置网站域名头
设置.key = “123456”  ' 设置传输密钥
设置.adminkey = “8888888”  ' 设置管理密钥

第四步:登录成功返回用户信息
用户信息界面.jpg
.版本 2

.程序集 窗口程序集_功能面板

.子程序 _功能面板_创建完毕

读取登录信息 ()

.子程序 读取登录信息

标签_uid.标题 = 用户.uid
标签_name.标题 = 用户.name
标签_groupid.标题 = 用户.groupid
标签_adminid.标题 = 用户.adminid
标签_token.标题 = 用户.token
标签_sgin.标题 = 用户.sgin
标签_datetime.标题 = 用户.datetime

.版本 2

.程序集 窗口程序集_功能面板

.子程序 _功能面板_创建完毕

读取登录信息 ()

.子程序 读取登录信息

标签_uid.标题 = 用户.uid
标签_name.标题 = 用户.name
标签_groupid.标题 = 用户.groupid
标签_adminid.标题 = 用户.adminid
标签_token.标题 = 用户.token
标签_sgin.标题 = 用户.sgin
标签_datetime.标题 = 用户.datetime


新秀网络验证登陆实例.e (10.94 KB, 下载次数: 2118)







回复

使用道具 举报

发表于 2021-5-30 00:53:54 | 显示全部楼层
为什么看不到内容
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

客户服务
周一至周日:09:00 - 21:00
客服QQ:3188639 QQ交流群:281079920

新秀网络验证是新一代简洁高效、云服务、独创功能融一体的新型管理收费框架系统,本框架专注于Discuz!二次开发规范要求,独立框架、代码分离、逻辑分离、独特加密、动态验证新型框架系统,专心服务客户。

Archiver|手机版|新秀网络验证系统 ( 豫ICP备2021033257号-1 )

GMT+8, 2022-5-27 14:49 , Processed in 0.251760 second(s), 59 queries , Redis On.

快速回复 返回顶部 返回列表